登录
    hello,it's me!

为eclipse指定相应的jdk版本

技术宅 破玉 349次浏览 2个评论

  最新版的eclipse要求用jdk1.8的版本,但是本机运行程序基本上需要jdk1.7的,所以为1.7指定了环境变量,在不修改环境变量的情况下,怎么才能让eclipse在1.8版本的jdk环境下运行呢?
  我们需要找到eclipse根目录,修改eclipse的配置文件
image
用文本编辑器打开eclipse.ini
在-vmargs参数前面配置-vm参数
image
再打开eclipse就可以了


华裳绕指柔, 版权所有丨如未注明 , 均为原创|转载请注明为eclipse指定相应的jdk版本
喜欢 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
(2)个小伙伴在吐槽
  1. 不用这么麻烦 preferences设置一下jdk就可以。。
    啊啊啊啊啊啊宅2017-06-29 13:53 回复
    • 不是eclipse编译环境,是eclipse的运行环境,因为eclipse也是用java实现的,他也依赖java环境,低版本的jdk无法打开高版本的eclipse,所以得为eclipse指定运行的jdk
      破玉2017-07-03 13:07 回复
返回顶部